Дашборды

Материал из Документация Ключ-АСТРОМ

Дашборды

Приложение

Предварительные требования

Разрешения

В следующей таблице описаны необходимые разрешения.

Разрешение Описание
app-engine:functions:run Позволяет пользователю запускать функции.
app-engine:apps:run Позволяет пользователю запускать приложения.
app-engine:edge-connects:read Позволяет пользователю читать конфигурацию EdgeConnect через функции.
document:environment-shares:read Позволяет пользователю получать доступ к общим дашбордам.
document:direct-shares:read Позволяет пользователю получать доступ к общим дашбордам.
state:user-app-states:write Позволяет приложению сохранять настройки представления, такие как выбранный временной диапазон или значения переменных.
state:user-app-states:read Позволяет приложению читать настройки представления, такие как выбранный временной диапазон или значения переменных.
state:user-app-states:delete Позволяет приложению удалять настройки представления.
davis:analyzers:read Позволяет пользователю читать конфигурацию анализаторов ИИ.
davis:analyzers:execute Позволяет пользователю запускать анализаторы ИИ.
storage:events:read Позволяет пользователю запрашивать записи из таблицы событий.
storage:logs:read Позволяет пользователю запрашивать записи из таблицы логов.
storage:user.events:read Позволяет пользователю запрашивать записи из таблицы пользовательских событий.
storage:metrics:read Позволяет пользователю запрашивать записи из таблицы метрик.
storage:entities:read Позволяет пользователю запрашивать сущности через хранилище.
storage:bizevents:read Позволяет пользователю запрашивать записи из таблицы бизнес-событий.
storage:system:read Позволяет пользователю запрашивать записи из всех системных таблиц.
storage:spans:read Позволяет пользователю запрашивать записи из таблицы спанов.
storage:buckets:read Позволяет пользователю запрашивать записи из бакетов хранилища.
storage:smartscape:read Позволяет пользователю запрашивать записи из таблицы Smartscape.
storage:fieldsets:read Позволяет пользователю запрашивать маскированные/конфиденциальные поля.
storage:bucket-definitions:read Позволяет пользователю читать определения бакетов хранилища через функции.
storage:user.sessions:read Позволяет пользователю запрашивать записи из таблицы пользовательских сессий.
storage:application.snapshots:read Позволяет пользователю запрашивать записи из таблицы снимков приложений.
storage:filter-segments:read Позволяет пользователю использовать сегменты.
storage:security.events:read Позволяет пользователю запрашивать записи из таблицы событий безопасности.
storage:files:read Позволяет пользователю читать данные из хранилища ресурсов.
storage:external-data:load Позволяет пользователю читать содержимое и метаданные из внешних хранилищ данных.
storage:external-data:list Позволяет пользователю перечислять объекты во внешних хранилищах данных.
document:documents:read Позволяет пользователю получать доступ к дашбордам.
document:documents:write Позволяет пользователю создавать и обновлять дашборды.
document:documents:delete Позволяет пользователю удалять дашборды.
document:trash.documents:read Позволяет пользователю получать доступ к удалённым дашбордам.
document:trash.documents:delete Позволяет пользователю безвозвратно удалять дашборды.
document:trash.documents:restore Позволяет пользователю восстанавливать удалённые дашборды.
settings:objects:read Позволяет пользователю читать объекты настроек через функции.
settings:schemas:read Позволяет пользователю читать схемы настроек через функции.
davis-copilot:nl2dql:execute Позволяет пользователю использовать ИИ-помощник для генерации DQL из естественного языка.
davis-copilot:dql2nl:execute Позволяет пользователю использовать ИИ-помощник для объяснения DQL на естественном языке.
davis-copilot:conversations:execute Позволяет пользователю использовать функцию диалога с ИИ-помощником.
automation:workflows:read Позволяет пользователю читать рабочие процессы автоматизации через функции.
automation:calendars:read Позволяет пользователю читать календари автоматизации через функции.
automation:rules:read Позволяет пользователю читать правила автоматизации через функции.
slo:slos:read Позволяет пользователю читать цели уровня сервиса.
hub:catalog:read Позволяет приложению читать информацию о списке изменений.
credential-vault:entries:read Позволяет приложению читать секреты из хранилища.

Начало работы

Концепции

Сценарии использования

С помощью Дашбордов вы можете:

  • Использовать готовые дашборды для мониторинга состояния системы в реальном времени.
  • Создавать собственные дашборды без усилий с помощью простого редактора или ИИ-помощника.
  • Углубляться в данные через бесшовную интеграцию с другими приложениями Ключ-АСТРОМ.
  • Использовать возможности ИИ для выявления аномалий и прогнозирования непосредственно на графиках.
  • Искать данные любого типа across платформы и объединять их даже с внешними данными в едином представлении.
  • Настраивать фильтры переменных для мониторинга различных ресурсов в рамках одного дашборда.

Плитки дашборда

В Дашбордах дашборд может состоять из нескольких плиток:

  • Explore: исследование данных, таких как логи, метрики и бизнес-события, с помощью интерфейса point-and-click.
  • Query: отображение данных, запрошенных через хранилище.
  • Code: отображение данных, возвращаемых кодом, выполняемым через функции Ключ-АСТРОМ.
  • Markdown: статическое содержимое, редактируемое в разметке Markdown.

Плитка Explore

Вы можете использовать опции Explore для исследования логов, метрик, бизнес-событий и многого другого с помощью интерфейса point-and-click. Без знаний DQL или программирования вы можете создавать и начинать использовать плитки дашборда за считанные минуты.

Плитка Query

Плитки запросов позволяют легко запрашивать данные из хранилища и визуализировать результат различными способами.

Плитка запроса состоит из поля ввода запроса, где вы можете написать запрос DQL. В поле ввода запроса используйте Ctrl+Space для вызова автодополнения в любой момент.

Вы можете управлять временным диапазоном для запроса через раскрывающийся список временного диапазона. Если временной диапазон определён в самом запросе, раскрывающийся список отключён.

Плитка Code

Раздел кода позволяет получать данные для вашего дашборда с помощью функций Ключ-АСТРОМ.

Плитка Markdown

Раздел Markdown может быть чем угодно — от небольшой заметки о чём-то на дашборде до целой страницы форматированной информации со ссылками и изображениями.

  • Легко редактировать.
  • Привлекательно выглядит.

Чтобы вставлять запросы из вашего дашборда с автодополнением, используйте Ctrl+Space.

Вы можете ссылаться на другие места в вашем дашборде и вне его.

Синтаксис ссылок Markdown

Ссылка в Markdown — это метка и ссылка вида [метка](адрес), где:

  • Метка — произвольный текст для отображения на ссылке в вашей плитке или разделе Markdown.
  • Адрес указывает, что открыть при выборе ссылки, например, веб-сайт или приложение Ключ-АСТРОМ.
Ссылка на Синтаксис и примеры
Веб-сайт [Моя метка](https://www.example.com/)
Приложение Блокноты [Моя метка](/ui/apps/astromkey.notebooks/notebooks)
Конкретный блокнот Синтаксис: [метка](/ui/apps/astromkey.notebooks/notebook/<notebookid>)

Пример: [Моя метка](/ui/apps/astromkey.notebooks/notebook/274edae4-dfe8-41fb-aced-5020fb1270bc)

Конкретный раздел блокнота Синтаксис: [метка](/ui/apps/astromkey.notebooks/notebook/<notebookid>#<sectionid>)

Пример: [Моя метка](/ui/apps/astromkey.notebooks/notebook/274edae4-dfe8-41fb-aced-5020fb1270bc#cb69caf1-52ed-4e73-8a3e-120e8cd7e8f8)

Приложение Дашборды [Моя метка](/ui/apps/astromkey.dashboards/)
Конкретный дашборд Синтаксис: [метка](/ui/apps/astromkey.dashboards/dashboard/<dashboardid>)

Пример: [Моя метка](/ui/apps/astromkey.dashboards/dashboard/9f24c36e-ca5f-401c-8e00-5e4b05c46bd2)

Конкретная плитка дашборда Синтаксис: [метка](/ui/apps/astromkey.dashboards/dashboard/<dashboardid>#tileIds=n)

Пример: [Моя метка](/ui/apps/astromkey.dashboards/dashboard/9f24c36e-ca5f-401c-8e00-5e4b05c46bd2#from=now%28%29-2h&to=now%28%29&tileIds=6)

Использование дашбордов

Использование сочетаний клавиш

Сочетания клавиш помогают работать быстрее в Дашбордах.

Чтобы просмотреть список сочетаний клавиш, в Дашбордах откройте меню и выберите Сочетания клавиш или используйте сочетание Shift+?.

Действие Сочетание клавиш
Общие
Множественный выбор плиток Выберите плитку, нажмите Space для получения двойной рамки вокруг плитки, используйте стрелки для перехода к другой плитке, затем снова нажмите Space для выбора нескольких плиток.
Выбрать все плитки Ctrl/Cmd+A
Удалить выбранные плитки Del
Копировать выбранные плитки в буфер обмена Ctrl/Cmd+C
Вставить плитки из буфера обмена Ctrl/Cmd+V
Добавить плитку Ctrl/Cmd+Shift+Enter
Плитки кода
Добавить код Shift+C
Выполнить код Ctrl/Cmd+Enter
Плитки данных
Добавить запрос Shift+D
Запустить запрос Ctrl/Cmd+Enter
Плитки Markdown
Добавить markdown Shift+M
Плитки целей уровня сервиса
Добавить цель уровня сервиса Shift+S
Переменные
Добавить переменную Shift+V
Плитки изображений
Добавить изображение Shift+I

Список дашбордов

Чтобы просмотреть список дашбордов

1. Перейдите в Дашборды.

2. На панели Дашборды раздел Последние открытые вами содержит недавно открытые дашборды.

3. Наведите курсор на имя дашборда и выберите меню доступных команд для этого дашборда.

Команды, которые вы видите в меню, зависят от ваших разрешений для этого дашборда. Например, вы не можете переименовать чужой дашборд, если вам не предоставили права на редактирование этого дашборда. (Но вы можете сделать копию общего дашборда и затем редактировать свою копию.)

  • Переименовать — включает редактирование имени дашборда.
  • Информация и метки — открывает панель для просмотра информации о дашборде, редактирования описания и управления метками.
  • Дублировать — создаёт копию дашборда.
  • Скачать — записывает дашборд в файл JSON, который вы можете импортировать.
  • Сменить владельца — назначает нового владельца дашборда.
  • Переместить в корзину — перемещает дашборд в корзину.

Значок после имени дашборда означает, что кто-то поделился этим дашбордом с вами.

Чтобы отобразить таблицу всех дашбордов, к которым у вас есть доступ — ваших собственных и всех, которыми с вами поделились — выберите Все дашборды.

Чтобы отсортировать таблицу, выберите заголовок Имя, Создан, Изменён или Открыт вами.

Чтобы отфильтровать таблицу, у вас есть несколько вариантов:

  • Все: список всех дашбордов.
  • Мои: список только дашбордов, которыми вы владеете.
  • Поделились со мной: список только дашбордов, которыми владеет кто-то другой, но которые предоставлены вам.
  • Готовые: список только готовых дашбордов. Вы можете дополнительно отфильтровать вкладку Готовые по источнику дашборда: Все готовые, Ключ-АСТРОМ, Расширения.
  • Корзина: список дашбордов в корзине.
  • Фильтр по имени или ID дашборда.
  • Владелец: фильтр по владельцу (доступен на вкладках Все и Поделились со мной).
  • Фильтр по меткам: фильтр по одной или нескольким меткам.

Отображение дашборда

Чтобы отобразить дашборд

1. Перейдите в Дашборды.

2. Выберите имя дашборда.

Взаимодействие с плиткой

Если вы видите что-то на дашборде, что хотите увеличить, вы можете развернуть это и рассмотреть поближе, а затем снова свернуть, когда закончите.

Когда вы разворачиваете плитку, она временно увеличивается до максимального размера дисплея, чтобы вы могли видеть детали выбранной плитки.

Чтобы развернуть плитку

1. Наведите курсор на плитку, чтобы отобразить команды плитки.

2. Выберите Развернуть.

Чтобы вернуться к обычному виду дашборда, выберите Свернуть в правом верхнем углу.

Обновление дашборда

Когда вы открываете дашборд впервые, частота обновления установлена в Выкл (без автоматического обновления).

Ручное обновление

Чтобы вручную обновить текущий дашборд, в правом верхнем углу дашборда выберите соответствующую кнопку.

Автоматическое обновление

Чтобы автоматически обновлять текущий дашборд, в правом верхнем углу дашборда выберите соответствующую кнопку и выберите частоту обновления.

  • Выкл отключает автоматическое обновление.
  • Другие настройки будут обновлять дашборд с указанным интервалом.

Если вы измените частоту обновления, эта частота запомнится при следующем открытии дашборда.

Частая частота обновления может держать вас буквально в курсе последних событий, но сложный дашборд может потребовать некоторого времени для пересчёта при каждом обновлении. Выберите частоту обновления, которая соответствует вашим потребностям и сложности дашборда.

Редактирование дашбордов только для чтения

Когда вы открываете документ (дашборд или блокнот), на который у вас нет прав на запись, вы всё равно можете редактировать документ во время сессии. После завершения у вас есть два варианта:

  • Сохранить изменения в новый документ.
  • Отменить изменения.

Пример:

1. Перейдите в Дашборды, откройте список готовых дашбордов и выберите дашборд Начало работы.

2. В левом верхнем углу рядом с именем документа указано Готовый.

3. Выберите плитку круговой диаграммы и затем выберите Редактировать.

4. Измените визуализацию с круговой на кольцевую.

5. Теперь вам предлагаются две кнопки: Сохранить как новый и Отменить изменения.

6. Используйте обновлённый дашборд по мере необходимости. У вас есть полный доступ на редактирование для этой сессии.

7. Когда закончите, выберите, что делать с изменениями:

  * Сохранить как новый — сохраняет изменения в новой копии отредактированного дашборда.
  * Отменить изменения — отменяет изменения и возвращает вас к неотредактированному дашборду только для чтения.

Выбор временного диапазона

Чтобы просмотреть или изменить настройки, применяемые ко всему дашборду

1. Отобразите дашборд.

2. В правом верхнем углу дашборда выберите Настройки.

3. Отображается панель Настройки.

4. Просмотрите или измените настройки по мере необходимости.

Пользовательский временной диапазон

Чтобы установить временной диапазон по умолчанию для дашборда

1. Отобразите дашборд.

2. В правом верхнем углу дашборда выберите Настройки.

3. Включите Пользовательский временной диапазон.

4. Выберите временной диапазон по умолчанию для выбранного дашборда.

Изменение этой настройки не обновляет немедленно временной диапазон текущего дашборда. Изменение применяется только к новой сессии с дашбордом (либо для другого пользователя, либо для того же пользователя, возвращающегося к дашборду в другой сессии).

Подробности о временных диапазонах дашборда см. в разделе «Выбор временного диапазона».

Сегмент по умолчанию

Чтобы просмотреть или изменить сегмент по умолчанию для дашборда

1. Отобразите дашборд.

2. В правом верхнем углу дашборда выберите Настройки.

3. Включите Сегмент по умолчанию.

4. Выберите сегмент по умолчанию для выбранного дашборда.

Изменение этой настройки не обновляет немедленно сегмент текущего дашборда. Изменение применяется только к новой сессии с дашбордом.

Подробности о сегментах дашборда см. в разделе «Выбор сегментов».

Переменные

Чтобы просмотреть или изменить переменные дашборда

1. Отобразите дашборд. 2. В правом верхнем углу дашборда выберите Настройки. 3. Отображается панель Настройки. 4. Выберите Переменные.

Подробности о переменных дашборда см. в разделе «Добавление переменной на дашборд».

Аннотации

Чтобы добавить аннотацию на дашборд

1. Выберите Настройки в правом верхнем углу дашборда.

2. Выберите Аннотации.

3. Выберите Создать аннотацию.

4. В разделе Данные выберите тип аннотации, которую хотите создать:

  * DQL: введите DQL.
  * Код: введите код.
  * Оповещение: выберите конфигурации оповещений.

5. Выберите Запустить.

6. В разделе Сопоставление данных сопоставьте поля:

  * Имя
  * Описание
  * Время начала (и Время окончания, если необходимо)

7. В разделе Настройки отображения настройте параметры отображения/ссылки.

Подробности см. в разделе «Добавление аннотаций на дашборд».

Временной диапазон

Временной диапазон описывает «когда» данных на дашборде.

Когда вы открываете дашборд впервые, применяется стандартный глобальный временной диапазон (Последние 2 часа).

Если вы измените настройку глобального временного диапазона для вашего дашборда, этот временной диапазон будет применён при следующем открытии дашборда. Однако есть исключения, описанные ниже.

Вы можете установить временной диапазон по умолчанию для конкретного дашборда, который применяется при каждом последующем открытии дашборда.

Вы можете установить временной диапазон для конкретной плитки. Эта настройка переопределяет глобальный временной диапазон.

Когда вы открываете дашборд по ссылке, если временной диапазон включён в ссылку, применяется временной диапазон ссылки, а временной диапазон дашборда по умолчанию игнорируется.

Изменение глобального временного диапазона

Чтобы изменить глобальный временной диапазон

1. В правом верхнем углу дашборда откройте меню селектора временного диапазона (по умолчанию Последние 2 часа).

2. Выберите новый временной диапазон.

  * Чтобы выбрать стандартный временной диапазон, выберите один из стандартных относительных временных диапазонов.
  * Чтобы определить пользовательский временной диапазон, определите его на панели Пользовательский временной диапазон и выберите Применить.
    * Используйте кнопки календаря для выбора календарных дат.
    * Отредактируйте полученные настройки От и До для точной настройки диапазона.

Когда вы изменяете глобальный временной диапазон:

  • Новый временной диапазон отображается в правом верхнем углу дашборда.
  • Содержимое дашборда пересчитывается и отображается в соответствии с новым временным диапазоном. Это переопределяет временной диапазон дашборда по умолчанию.
  • Это не влияет на переопределения временного диапазона для конкретных плиток. Временные диапазоны конкретных плиток имеют приоритет над любыми глобальными настройками временного диапазона.

Временной диапазон дашборда по умолчанию

Чтобы установить временной диапазон по умолчанию для дашборда

1. Отобразите дашборд.

2. В правом верхнем углу дашборда выберите Настройки.

3. Включите Пользовательский временной диапазон.

4. Выберите временной диапазон по умолчанию для выбранного дашборда.

Изменение этой настройки не обновляет немедленно временной диапазон текущего дашборда. Изменение применяется только к новой сессии с дашбордом.

Переопределение временного диапазона для конкретной плитки

Чтобы указать пользовательский временной диапазон в плитке дашборда

1. Отредактируйте плитку.

2. На панели редактирования включите Пользовательский временной диапазон.

3. Выберите временной диапазон для применения к выбранной плитке.

Этот временной диапазон переопределяет временной диапазон дашборда, установленный в правом верхнем углу дашборда. Используя этот метод, дашборд может иметь несколько плиток, где каждая плитка имеет свой собственный временной диапазон.

Вы также можете указать пользовательский временной диапазон в запросе DQL плитки данных. Если вы используете этот метод (с временным диапазоном, указанным в запросе), вышеуказанная настройка интерфейса отключается и используется временной диапазон, указанный в запросе.

Пример указания временного диапазона в DQL:

fetch [recordtype], from:now() - 2h
    | ....

Подробности об указании временного диапазона в DQL см. в документации по DQL.

Выбор сегментов

Чтобы фильтровать данные, вы можете указать сегменты на двух уровнях: дашборд и плитка. Выбор сегментов на уровне плитки переопределяет выбор сегментов на уровне дашборда.

Сегменты на уровне дашборда

Чтобы выбрать сегменты на уровне дашборда

1. Отобразите дашборд.

2. Откройте селектор сегментов в верхней части дашборда и в разделе Фильтровать по сегментам выберите сегмент.

3. Если сегмент требует дополнительного выбора значения, выберите его сейчас.

4. Чтобы добавить другой сегмент, выберите Сегмент. Повторите этот шаг для каждого сегмента, который хотите добавить.

5. Выберите Применить, чтобы применить выбор и отфильтровать данные на дашборде.

Селектор сегментов теперь отображает имя выбранного сегмента или, если вы выбрали более одного сегмента, количество выбранных сегментов.

  • Чтобы изменить выбор сегмента, выберите селектор снова, внесите изменения и выберите Применить.
  • Чтобы управлять сегментами в целом (список, создание, просмотр, редактирование, удаление), выберите селектор и затем выберите ссылку Управление сегментами.

Сегменты на уровне плитки

Чтобы выбрать сегменты на уровне плитки

1. Отобразите дашборд.

2. Выберите плитку и затем выберите соответствующую кнопку в элементах управления плитки, чтобы отредактировать плитку.

3. На панели редактирования включите Пользовательские сегменты.

4. В списке Пользовательские сегменты выберите сегмент.

5. Если сегмент требует дополнительного выбора значения, выберите его сейчас.

6. Чтобы добавить другой сегмент, выберите Сегмент. Повторите этот шаг для каждого сегмента, который хотите добавить для выбранной плитки.

7. Выберите Применить, чтобы применить выбор и отфильтровать данные на плитке.

Селектор сегментов теперь отображает имя выбранного сегмента или, если вы выбрали более одного сегмента, количество выбранных сегментов.

  • Чтобы изменить выбор сегмента, выберите селектор снова, внесите изменения и выберите Применить.
  • Чтобы управлять сегментами в целом, выберите селектор и затем выберите ссылку Управление сегментами.

Добавление аннотаций

Аннотации позволяют указывать значимые события, такие как развёртывания, инциденты или изменения конфигурации, на графике временных рядов. Это помогает коррелировать поведение метрик с тем, что происходило в вашей среде при диагностике или обзоре тенденций.

Аннотации управляются данными, поэтому они остаются актуальными по мере изменения ваших данных. Вы можете создать аннотацию тремя способами:

  • Запрос DQL, возвращающий метки времени и связанные метаданные.
  • Фрагмент кода, возвращающий записи аннотаций.
  • Выбор оповещения, использующий одну или несколько конфигураций обнаружения аномалий для автоматической генерации запроса.

Когда вы применяете аннотацию к графику, результат сопоставляется с графиком, чтобы вы могли видеть, что произошло и когда это произошло.

Чтобы добавить аннотацию на дашборд

1. Выберите Настройки в правом верхнем углу дашборда.

2. Выберите Аннотации.

3. Выберите Создать аннотацию.

4. В разделе Данные выберите тип аннотации, которую хотите создать:

  * DQL: введите DQL.
  * Код: введите код.
  * Оповещение: выберите конфигурации оповещений.

5. Выберите Запустить.

6. В разделе Сопоставление данных сопоставьте поля:

  * Имя
  * Описание
  * Время начала (и Время окончания, если необходимо)

7. В разделе Настройки отображения настройте параметры отображения/ссылки.

Подробности см. в разделе «Добавление аннотаций на дашборд».

Настройки дашборда

Чтобы просмотреть или изменить настройки, применяемые ко всему дашборду

1. Отобразите дашборд.

2. В правом верхнем углу дашборда выберите Настройки.

3. Отображается панель Настройки.

4. Просмотрите или измените настройки по мере необходимости.

Запуск плитки кода

Когда вы открываете документ от другого пользователя, вы можете увидеть следующее сообщение:

Этот дашборд содержит пользовательский код. Он доступен только для чтения, пока вы не проверите код и не выберете «Принять и запустить».

Когда вы запускаете плитку кода или раздел, написанный другим человеком, Ключ-АСТРОМ выполняет JavaScript этого человека, используя вашу учётную запись и ваши разрешения. Это мощная функция, но её нужно использовать правильно и ответственно. Код JavaScript может получать доступ к внешним API от вашего имени (используя вашу учётную запись и разрешения).

Чтобы проверить код

1. Выберите Проверить весь код.

2. Страница Проверка кода отображает код каждой плитки кода в отдельном поле.

3. Проверьте код и решите, хотите ли вы его запустить.

4. Если вы хотите запустить код, вы можете одобрить его только на этот раз или навсегда.

  * Чтобы запустить код только на этот раз, выберите Принять и запустить. В следующий раз при открытии этого документа вас снова попросят проверить код перед запуском.
  * Чтобы навсегда принять код в этом документе, выберите Всегда доверять коду в этом документе и затем выберите Принять и запустить.

Скачивание результата

Чтобы скачать (экспортировать) результат текущей плитки дашборда или раздела блокнота в локальный файл

1. Выберите плитку или раздел.

2. На панели команд откройте меню и выберите Скачать результат > [формат].

Доступные форматы зависят от визуализации.

  • CSV: результат скачивается в локальный файл с разделителями-запятыми (*.csv). Этот параметр включает форматирование таблицы, такое как видимые столбцы и форматирование единиц измерения.
  • CSV (необработанный): результат скачивается в локальный файл с разделителями-запятыми (*.csv). Этот параметр включает полные неформатированные данные.
  • JSON: результат скачивается в локальный файл JSON (*.json).

Некоторые визуализации не предлагают возможности скачать результат.

Возможная проблема с импортом CSV в Excel

Когда вы экспортируете результаты в файл CSV — будь то CSV или CSV (необработанный) — с разрывами строк в любом столбце/поле результата, а затем открываете файл в Microsoft Excel или пытаетесь преобразовать файл в таблицу с помощью опции Excel Данные > Текст по столбцам, вы можете столкнуться с проблемой, когда разрывы строк неправильно отображаются в Excel. Это вызвано ограничением Excel.

Чтобы избежать этой проблемы, используйте опцию Excel Данные > Из текста/CSV.

Управление дашбордами

Добавление дашборда в Dock

Чтобы добавить дашборд в Dock для удобного доступа

1. Отобразите дашборд.

2. Откройте меню рядом с именем дашборда (в левом верхнем углу дашборда).

3. Выберите Добавить в dock.

Если вы измените имя дашборда, оно автоматически обновится в Dock.

Чтобы удалить дашборд из Dock

1. Наведите курсор на имя дашборда в Dock.

2. Выберите Открепить от dock.

Переименование дашборда

Чтобы переименовать дашборд на панели «Дашборды»

1. Перейдите в Дашборды.

2. Раздел Последние открытые вами содержит недавно открытые дашборды.

3. Наведите курсор на имя дашборда, который хотите переименовать, и выберите > Переименовать.

Если опция переименования недоступна, у вас нет прав на редактирование этого дашборда.

Управление метками

Метки позволяют организовывать и фильтровать ваши дашборды. Вы можете добавить несколько меток к дашборду, а затем использовать Фильтр по меткам в списке дашбордов для сужения результатов.

Чтобы добавить или удалить метки на дашборде

1. Откройте меню рядом с именем дашборда.

2. Выберите Информация и метки.

3. В разделе Метки выберите поле Добавить метки и введите имя метки.

  * Чтобы назначить существующую метку, выберите её из предложений.
  * Чтобы создать новую метку, введите имя и нажмите Enter.

4. Чтобы удалить метку, выберите соответствующую кнопку рядом с именем метки.

Чтобы отфильтровать список дашбордов по метке

1. Перейдите в Дашборды > Все дашборды.

2. Выберите Фильтр по меткам и выберите одну или несколько меток. Вы также можете искать метку по имени.

3. Список обновляется, показывая только дашборды с выбранными метками.

Дублирование дашборда

Чтобы дублировать дашборд на панели «Дашборды»

1. Перейдите в Дашборды.

2. Раздел Последние открытые вами содержит недавно открытые дашборды.

3. Наведите курсор на имя дашборда, который хотите дублировать, и выберите > Сделать копию.

Чтобы сделать копию текущего дашборда

1. В верхней части дашборда откройте меню дашборда рядом с именем дашборда.

2. Выберите Дублировать из меню.

Создаётся копия с именем Копия + имя текущего дашборда. Копия теперь отображается на панели Дашборды.

Совместное использование дашборда

Если вы владеете дашбордом или блокнотом, вы можете поделиться им.

Есть три способа поделиться документом с другими пользователями Ключ-АСТРОМ в вашей компании:

  • Доступ для всех (только просмотр): предоставить доступ только для просмотра всем в вашей среде Ключ-АСТРОМ.
  • Поделиться доступом: создать и поддерживать список пользователей и групп пользователей с доступом к документу.
  • Поделиться ссылками: создать ссылки (URL), указывающие на ваш документ, и распространить их по удобным вам каналам (например, электронная почта).

Эти методы не являются взаимоисключающими. Например, вы можете вести список пользователей для постоянного доступа к документу (возможно, все в определённой группе регулярно редактируют документ) и создавать и распространять ссылки только для просмотра для более широкой аудитории по мере необходимости.

В любом случае вы контролируете, могут ли люди редактировать документ или только просматривать его.

Подробности о совместном использовании документов см. в разделе «Совместное использование документов».

Управление версиями дашборда

Версии дашборда сохраняются автоматически.

  • Вы можете получить доступ к 50 последним версиям вашего дашборда.
  • Каждая версия дашборда доступна в течение 30 дней.

Чтобы просмотреть и управлять версиями дашборда

1. Отобразите ваш дашборд.

2. В правом верхнем углу вашего дашборда выберите соответствующую кнопку.

3. Отображается меню последних версий текущего дашборда:

  * Дата
  * Время
  * Имя человека, создавшего эту версию

4. Из любой записи версии в меню Версии вы можете выбрать действия для конкретной версии:

  * Предварительный просмотр — отображает предварительный просмотр выбранной версии.
  * Восстановить — переключает ваш дашборд на выбранную версию.
  * Сделать копию — создаёт новый дашборд из выбранной версии и отображает новый дашборд. Оригинальный дашборд остаётся без изменений.
  * Скачать — сохраняет файл JSON выбранной версии дашборда на ваш локальный компьютер.
  * Предварительный просмотр в новой вкладке — отображает предварительный просмотр выбранной версии в новой вкладке браузера.
  * Удалить эту версию — удаляет выбранную версию.

5. Чтобы просмотреть и управлять всеми версиями дашборда в отдельном окне, перейдите в нижнюю часть меню Версии и выберите Показать все.

Подробности см. в разделе «Управление версиями документов».

Смена владельца дашборда

Когда вы создаёте документ (дашборд или блокнот), вы являетесь владельцем. Чтобы передать право собственности на документ другому пользователю Ключ-АСТРОМ:

1. Откройте меню документа и выберите Сменить владельца.

2. Найдите и выберите нового владельца, затем выберите Сменить владельца.

Когда вы меняете владельца документа, вы немедленно теряете доступ к документу.

  • Убедитесь, что вы готовы передать право собственности, прежде чем выбирать эту команду.
  • Вы можете восстановить доступ к документу только если новый владелец даст вам разрешение.
  • После завершения передачи новый владелец получит электронное письмо о передаче права собственности на документ.

Скачивание дашборда

Чтобы скачать (экспортировать) отображаемый в данный момент дашборд как JSON

1. В верхней части дашборда откройте меню справа от имени дашборда.

2. Выберите Скачать из меню.

Определение текущего дашборда скачивается в локальный файл JSON.

Чтобы скачать (экспортировать) дашборд с боковой панели «Дашборды»

1. Перейдите в Дашборды.

2. В разделе Последние открытые вами наведите курсор на имя дашборда, который хотите экспортировать, и выберите Скачать из меню.

Дашборд скачивается в локальный файл JSON, который вы можете загрузить.

Если ваш дашборд не указан в разделе Последние открытые вами, выберите Все дашборды, чтобы отобразить таблицу всех дашбордов, к которым у вас есть доступ (ваших дашбордов или дашбордов, которыми с вами поделились). Оттуда вы можете найти дашборд и выбрать Скачать из меню.

Загрузка дашборда

Чтобы загрузить (импортировать) JSON-определение дашборда с боковой панели «Дашборды»

1. Перейдите в Дашборды.

2. На панели Дашборды слева выберите Загрузить.

3. Найдите и откройте файл JSON-определения дашборда.

Чтобы загрузить (импортировать) JSON-определение дашборда из таблицы «Дашборды»

1. Перейдите в Дашборды.

2. На панели Дашборды слева выберите Все дашборды.

3. Таблица Дашборды отображает все дашборды по Имени и дате Последнего изменения.

4. В левом верхнем углу страницы выберите Загрузить. 5. Найдите и откройте файл JSON-определения дашборда.

Загруженный дашборд:

  • Открывается в Ключ-АСТРОМ.
  • Если вы видите сообщение о запуске пользовательского кода при загрузке дашборда, см. раздел «Предупреждения о запуске кода» для получения дополнительной информации.
  • Добавляется в ваш список Последние открытые вами.
  • Добавляется на страницу Дашборды с Последним изменением, установленным на дату и время загрузки.

Удаление дашборда

Чтобы удалить любой дашборд на странице «Дашборды»

1. Перейдите в Дашборды.

2. На панели Дашборды слева выберите Все дашборды.

3. Таблица отображает все дашборды по Имени и дате Последнего изменения.

4. На странице Дашборды выберите Переместить в корзину для дашборда, который хотите удалить.

Дашборды через API: лучшие практики

При создании или управлении дашбордами через API эти лучшие практики могут облегчить вам жизнь.

  • Чтобы получить надёжное начало, создайте дашборд в приложении Дашборды, а затем скачайте файл конфигурации дашборда.
  • Чтобы проверить изменения, внесённые через API, загрузите файл в Дашборды. Всё ли ещё выглядит как ожидалось?
  • Будьте осторожны с изменениями макета, так как пустые вертикальные пространства вызывают автоматическое смещение плиток вверх при загрузке документа и появление кнопки Отменить изменения.
  • Чтобы детально изучить изменения, выберите Сохранить как новый, чтобы скачать документ и сравнить его с оригинальной версией.
  • Не устанавливайте свойство version конфигурации в произвольное значение. Это внутреннее свойство, необходимое для целей миграции.

Создание и редактирование дашбордов

Создание дашборда

Самый быстрый и простой способ исследовать данные — с помощью наших новых плиток и разделов Explore. За несколько секунд вы можете найти и проанализировать свои логи, метрики или бизнес-события. DQL не требуется!

Чтобы создать новый дашборд

1. Перейдите в Дашборды.

2. Выберите Дашборд.

После создания пустого дашборда вам нужно добавить в него плитки.

  • Запрос к хранилищу
  • Добавить код
  • Добавить Markdown
  • Добавить переменную
  • Добавить предопределённую плитку
  • Добавить изображение

Запрос к хранилищу

Чтобы выполнить запрос к хранилищу

1. В правом верхнем углу дашборда откройте меню Добавить и выберите DQL.

  * Сочетание клавиш: Shift+D

2. Справа открывается боковая панель конфигурации с двумя вкладками:

  * Данные
  * Визуализация

3. На вкладке Данные используйте Ключ-АСТРОМ Query Language (DQL) для определения вашего запроса.

4. Выберите Запустить, чтобы выполнить запрос.

5. На вкладке Визуализация выберите формат визуализации для ваших результатов.

  * Соответствующий значок означает, что тип визуализации недоступен для вашего запроса.

6. В разделе селектора Визуализация разверните разделы параметров, чтобы настроить параметры визуализации по мере необходимости.

7. Закройте боковую панель, когда закончите.

  * Если вы хотите вернуться к этим настройкам, выберите вашу плитку, чтобы отобразить их.

Подробности см. в разделе «Добавление данных на дашборд».

Добавление кода

Чтобы добавить код на дашборд

1. В правом верхнем углу дашборда откройте меню Добавить и выберите Код.

  * Сочетание клавиш: Shift+C

2. На дашборд добавляется пустая плитка, и справа открывается боковая панель Параметры.

3. Необязательно: в поле Заголовок плитки введите заголовок для отображения в верхней части вашей плитки.

4. В пронумерованном поле Код введите пользовательский JavaScript для получения внешних данных из любого доступного API. Используйте Fetch API для получения данных из внешних API.

  * Чтобы убедиться, что ваши запросы не заблокированы, попросите администратора разрешить ваши внешние источники данных, добавив их в Внешние запросы.
  * Внешние запросы включают исходящие сетевые подключения из вашей среды Ключ-АСТРОМ к внешним сервисам. Они позволяют контролировать доступ к публичным конечным точкам из AppEngine с помощью функций приложений и функций в Дашбордах, Блокнотах и Автоматизациях.
  * Перейдите в Настройки > Общие > Внешние запросы.
  * Выберите Новый шаблон хоста.
  * Добавьте доменные имена.
  * Выберите Добавить.
  * Таким образом вы можете гранулярно контролировать веб-сервисы, к которым могут подключаться ваши функции.
  * Не включайте префикс адреса. Например, если адрес https://www.example.com, добавьте только www.example.com.

Подробности см. в разделе «Добавление кода на дашборд».

Добавление markdown

Чтобы добавить плитку markdown на дашборд

1. В правом верхнем углу дашборда откройте меню Добавить и выберите Добавить markdown.

  * Сочетание клавиш: Shift+M

2. Справа открывается боковая панель Параметры.

3. На боковой панели Параметры введите ваш текст.

  * Используйте Markdown для форматирования текста и добавления ссылок и изображений.
  * Плитка обновляется по мере редактирования.
  * Во время редактирования текста нажмите Ctrl+Space, чтобы увидеть варианты.

4. Закройте боковую панель Параметры, когда закончите.

Подробности см. в разделе «Добавление Markdown на дашборд».

Добавление переменной

Используйте переменные для фильтрации ваших дашбордов, в качестве значений переменных в плитках кода и в качестве заполнителей в заголовках плиток и тексте плиток Markdown.

Чтобы добавить переменную на дашборд

1. В заголовке дашборда откройте меню Добавить и выберите Переменные.

  * Сочетание клавиш: Shift+V

2. Отображается панель Переменная.

3. Определите переменную.

  * Имя: имя переменной. Оно отображается на дашборде и может содержать любые символы.
    * Ключ-АСТРОМ выводит ключ из имени, заменяя любой символ, не являющийся буквой или цифрой, на _. Добавьте префикс $ к ключу, чтобы ссылаться на переменную в запросах, коде и заголовках.
    * Ключ не может начинаться с зарезервированного префикса dt_.
    * Чтобы найти ключ переменной, откройте её меню или проверьте выноску, отображаемую, пока переменная ещё не используется.
  * Тип: может быть одним из следующих:
    * DQL: значение возвращается из запроса, который вы вводите при определении переменной.
      * Выберите Запустить, чтобы протестировать ваш запрос.
    * Код: значение возвращается из кода, который вы вводите при определении переменной.
    * Список: список значений с разделителями-запятыми (CSV).
      * Чтобы определить возможные значения, введите их (через запятую) в поле под Данными.
      * Чтобы определить значение по умолчанию, выберите одно из списка Значение по умолчанию.
      * Чтобы разрешить выбор нескольких значений одновременно, включите Множественный выбор.
    * Свободный текст: произвольный текст. Вы можете ввести Значение по умолчанию. Ваши изменения сохраняются автоматически.

4. Настройте Параметры отображения.

  * Если раскрывающийся список переменной должен отображаться на дашборде, включите Отображать как фильтр на дашборде.
  * Отключите его, когда хотите скрыть его, например, когда переменная используется как статическое значение across плиток, но не должна отображаться пользователю дашборда.
  * Если пользователи вашего дашборда должны иметь возможность выбирать несколько значений одновременно в раскрывающемся списке переменной, включите Множественный выбор.
  * Отключите его, когда хотите использовать только отдельные значения раскрывающегося списка переменной.
  * Выберите Значение по умолчанию для раскрывающегося списка переменной. Если вы ничего не введёте в это поле, будет выбрано первое доступное значение.

5. Когда закончите, выберите < Переменная в верхней части, чтобы перейти на панель Переменные, или выберите соответствующую кнопку, чтобы закрыть панель Переменные.

Переменные в дашбордах могут быть определены как зависимые от других переменных.

Значение переменной пересчитывается, если её определение ссылается на другую переменную и значение другой переменной изменяется.

Например, если значение переменной A изменяется, значение любой переменной, определение которой ссылается на переменную A, пересчитывается.

Циклы не допускаются.

Например, если значение переменной A зависит от значения переменной B, значение переменной B не может зависеть от значения переменной A.

Подробности см. в разделе «Добавление переменной на дашборд».

Добавление предопределённой плитки

Чтобы добавить предопределённую плитку на ваш дашборд

1. В правом верхнем углу дашборда откройте меню Добавить.

  * Сочетание клавиш: Ctrl/Cmd+Shift+Enter

2. Прокрутите вниз до раздела Библиотека и выберите предопределённую плитку.

  * Поиск: используйте поле поиска в верхней части меню, чтобы найти плитку по имени.

3. После выбора предопределённой плитки панель редактирования отображает добавленную вами плитку.

4. Отредактируйте запрос или код и настройки визуализации по мере необходимости.

5. Выберите Запустить, чтобы увидеть результаты.

6. Закройте боковую панель, когда закончите.

Подробности см. в разделе «Добавление предопределённой плитки из библиотеки».

Добавление изображения

Откройте меню Добавить и выберите Изображение или используйте сочетание клавиш Shift+I.

Подробности см. в разделе «Добавление изображения на дашборд».

Анализ данных с помощью ИИ

Чтобы анализировать данные с помощью анализаторов данных Ключ-АСТРОМ Intelligence

Исследуйте временной ряд.

Пример:

В вашем документе (дашборде или блокноте):

1. Выберите соответствующую кнопку, чтобы добавить новый раздел или плитку, затем выберите Метрики для исследования метрик.

2. В разделе Выбрать метрику выберите Инфраструктура > CPU > CPU usage %.

3. Установите Разделить по в host.name.

4. Установите Лимит на максимальное количество серий для анализа. Анализатор данных Ключ-АСТРОМ Intelligence в настоящее время поддерживает анализ до 1000 серий.

5. Запустите запрос.

6. На панели параметров справа прокрутите вниз и разверните ИИ.

7. На панели ИИ установите Анализаторы на анализатор, который хотите использовать, и затем настройте анализатор.

  * Обзор обнаружения аномалий см. в разделе «Обнаружение аномалий».
  * Подробности о настройках обнаружения аномалий см. в разделе «Конфигурация обнаружения аномалий».
  * Подробности о настройках анализатора прогнозирования см. в разделе «Предиктивный анализ ИИ Ключ-АСТРОМ Intelligence».

Обнаружение аномалий: Автоадаптивное пороговое обнаружение аномалий

  • Количество колебаний сигнала — сколько раз колебание сигнала добавляется к базовой линии для получения фактического порога для оповещения.
  • Условие оповещения — ваш выбор зависит от того, хотите ли вы знать, когда метрика выше, ниже или вне (выше или ниже) нормального диапазона.
  • Подробности см. в разделе «Конфигурация обнаружения аномалий».

Обнаружение аномалий: Сезонное базовое обнаружение аномалий

  • Допуск — чем выше допуск, тем шире доверительная полоса, что приводит к меньшему количеству срабатываний.
  • Условие оповещения — ваш выбор зависит от того, хотите ли вы знать, когда метрика выше, ниже или вне нормального диапазона.
  • Подробности см. в разделе «Конфигурация обнаружения аномалий».

Обнаружение аномалий: Статическое пороговое обнаружение аномалий

  • Порог — жёсткий предел, который метрика не должна нарушать.
  • Единица измерения — единица значения.
  • Условие оповещения — ваш выбор зависит от того, хотите ли вы знать, когда метрика выше или ниже порогового значения.
  • Предложить порог — ИИ может помочь вам найти правильный порог на основе исторических данных.
  • Подробности см. в разделе «Конфигурация обнаружения аномалий».

Прогнозирование: Прогноз

  • Точки данных для прогнозирования — общее количество шагов, на которые прогнозируется временной ряд. Большее количество шагов обычно приводит к менее надёжным прогнозам и более длительному времени выполнения анализатора.
  • Смещение прогноза — смещение для начала прогноза. Например, если смещение установлено на 2, последние две точки данных игнорируются, и прогноз для этих точек также возвращается.
  • Подробности см. в разделе «Предиктивный анализ ИИ Ключ-АСТРОМ Intelligence».

Расширенные настройки (для обнаружения аномалий)

Вы можете использовать значения по умолчанию или включить Показать расширенные свойства для точной настройки этих параметров.

  • Оповещать о missing data — оповещать, если данные не обнаружены в скользящем окне.
  • Нарушающие образцы — количество образцов в скользящем окне, которые должны нарушить, чтобы вызвать событие.
  • Скользящее окно — количество образцов, формирующих скользящее окно.
  • Образцы для снятия оповещения — количество образцов в скользящем окне, которые должны вернуться к норме, чтобы закрыть событие.

По умолчанию анализатор не включён. Чтобы включить его, переключите переключатель в верхней части панели редактирования (переключите с Анализ данных ИИ не активен на Анализ данных ИИ активен).

Чтобы просмотреть результаты, выберите визуализацию Анализ ИИ и разверните раздел графика Анализ ИИ, чтобы просмотреть или изменить настройки, специфичные для визуализации:

Визуализация Анализ ИИ имеет два раздела: график и визуализация. Вы можете использовать настройку Видимые разделы для отображения одного или обоих из них.

  • Все — показать график и таблицу. График отражает выбор в вашей таблице.
  • Таблица — показать только таблицу. Вы можете сортировать столбцы, отображающие значок сортировки в заголовке. Выберите заголовок столбца, чтобы переключить порядок сортировки по возрастанию или по убыванию.
  • График — показать только график. Используйте таблицу для выбора записей, которые хотите показать на графике.

Пример: аномальный процент использования CPU

Чтобы обнаружить, когда процент использования CPU превышает 70 процентов, в вашем документе (дашборде или блокноте):

1. Выберите соответствующую кнопку, чтобы добавить новый раздел или плитку, затем выберите Метрики для исследования метрик.

2. В разделе Выбрать метрику выберите Инфраструктура > CPU > CPU usage %.

3. Установите Разделить по в host.name.

4. Установите Лимит на максимальное количество серий для анализа. Анализатор в настоящее время поддерживает анализ до 1000 серий.

5. Выберите Запустить.

6. На панели редактирования разверните ИИ.

7. В списке Анализаторы выберите Статическое пороговое обнаружение аномалий.

8. Установите Порог равным 70 (введите значение) и Условие оповещения — Оповещать, если метрика выше (по умолчанию).

9. Активируйте анализатор: в верхней части панели редактирования переключите с Анализ данных ИИ не активен на Анализ данных ИИ активен.

10. Чтобы просмотреть результаты, выберите визуализацию Анализ ИИ. Разверните раздел графика Анализ ИИ, чтобы увидеть настройки, специфичные для визуализации.

11. В разделе графика Анализ ИИ установите Видимые разделы на Все.

12. Просмотрите результаты.

В этом примере мы выбрали хосты, которые превысили порог.

  • График показывает линию для выбранной метрики (CPU usage %) для каждого выбранного хоста.
  • Красная полоса в верхней части визуализации указывает, где был превышен порог для этой метрики.
  • Таблица под графиком содержит выбранные хосты.

Изменение значений переменных

Если дашборд имеет одну или несколько переменных, они перечислены по имени в левом верхнем углу дашборда, под именем дашборда. Когда вы изменяете значения переменных, содержимое дашборда пересчитывается и отображается в соответствии с новыми значениями.

Чтобы изменить значение переменной

1. В левом верхнем углу дашборда найдите имя переменной.

2. Используйте меню или поле редактирования под именем переменной, чтобы изменить значение.

  * Если переменная допускает только один выбор (значение) за раз, выберите значение, которое хотите применить к дашборду.
  * Если переменная допускает несколько выборов (значений) за раз, установите флажок для каждого значения, которое хотите применить к дашборду. Имя меню для этой переменной показывает, сколько значений выбрано.
  * Для переменной Свободный текст вы можете редактировать текст в поле под именем переменной.

Копирование в другой документ

Вы можете скопировать плитку дашборда в другой документ (например, в другой дашборд или блокнот).

Например, простой способ начать новый блокнот — скопировать многоразовые плитки из существующих дашбордов в новый блокнот, а затем отредактировать скопированные разделы как часть нового блокнота.

Чтобы скопировать плитку дашборда в блокнот (как раздел блокнота)

1. На дашборде выберите плитку, которую хотите скопировать в блокнот.

2. Откройте меню и выберите Блокноты Добавить в блокнот.

3. В разделе Выбрать назначение:

  * Если вы хотите создать новый блокнот с выбранной плиткой дашборда в качестве раздела, выберите Новый блокнот.
  * Если вы хотите добавить выбранную плитку дашборда как ещё один раздел в существующий блокнот, выберите существующий блокнот из списка и затем выберите Подтвердить.

4. Блокнот открывается с выбранной плиткой, скопированной в него как раздел блокнота.

Чтобы скопировать плитку дашборда в другое приложение (не Блокноты), откройте меню и выберите Открыть с помощью, затем выберите целевое приложение.

Подробности см. в разделе «Детализация и навигация».

Редактирование плитки

Чтобы отредактировать плитку

1. Выберите плитку, чтобы отобразить команды плитки.

2. Выберите Редактировать.

3. Справа открывается панель Параметры для отображения конфигурации плитки или раздела.

4. Выберите и перетащите элемент управления расширением влево или вправо по мере необходимости, чтобы изменить размер панели Параметры для лучшего просмотра кода.

Добавление или редактирование заголовка плитки

Вы можете добавить заголовок к любой плитке дашборда (кроме плитки Markdown).

Независимо от настройки заголовка, строка заголовка создаётся автоматически по мере необходимости для отображения индикаторов плитки, таких как предупреждение или указание пользовательского временного диапазона плитки.

1. Выберите плитку и отредактируйте её.

2. Заголовок отображается в поле в верхней части панели редактирования плитки.

  * Если у плитки нет заголовка, в поле отображается Плитка без названия.

3. Отредактируйте заголовок. Ваши правки отображаются по мере ввода.

Заголовок может включать эмодзи (такие как 😃 и 🌍 и ❤️) и переменные.

Пример:

1. На вашем дашборде определите переменные с именами Status и Emoji.

2. Установите заголовок в Current $Emoji status is $Status.

3. Установите переменную Status в Good.

4. Установите переменную Emoji в 🌍.

5. Заголовок будет отображаться как Current 🌍 status is Good, и он будет автоматически обновляться при изменении значений переменных.

Чтобы удалить заголовок плитки, выберите плитку и отредактируйте её, затем очистите поле заголовка.

Настройка визуализации плитки

Каждая визуализация имеет настройки, специфичные для визуализации.

Чтобы отредактировать визуализацию плитки, см. инструкции по визуализации.

Редактирование JSON дашборда

Вы можете редактировать базовый JSON дашборда непосредственно в Дашбордах. Это позволяет переупорядочивать плитки, вносить массовые изменения или копировать фрагменты JSON между дашбордами и средами без вызовов API.

Чтобы отредактировать JSON дашборда

1. Отобразите дашборд.

2. Откройте меню рядом с именем дашборда (в левом верхнем углу дашборда).

3. Выберите Редактировать JSON.

4. Внесите изменения.

5. Выберите Сохранить. Редактор закрывается, и ваши изменения отражаются в дашборде.

Чтобы использовать другую среду редактирования, выберите Копировать JSON в правом верхнем углу редактора. После внесения изменений в другом редакторе вставьте отредактированный JSON обратно и выберите Сохранить.

Если ваш дашборд содержит ошибки валидации, вам нужно исправить их перед сохранением.

Подробности см. в разделе «Валидация дашборда».

Макет

Изменение размера плитки

Чтобы изменить размер одной плитки

1. Наведите курсор на плитку.

2. Выберите и перетащите элементы управления изменением размера (например, ) в нижних углах плитки, чтобы изменить размеры плитки.

Чтобы помочь вам выбрать конкретный размер и положение:

  • Размер плитки отображается на панели команд плитки.
  • Сетка отображается на фоне.

Чтобы изменить размер нескольких плиток одновременно

1. Удерживая Ctrl, щёлкните плитки, размер которых хотите изменить.

2. Выберите и перетащите элементы управления изменением размера (например, ) в нижних углах выбранных плиток, чтобы изменить размеры выбранных плиток.

Перемещение плитки

Вы можете перемещать одну плитку за раз или выбирать и перемещать несколько плиток одновременно.

Чтобы переместить плитку, перетащите плитку на новое место.

  • Если у плитки есть заголовок, выберите и перетащите строку заголовка, чтобы переместить плитку.
  • Если у плитки нет заголовка, выберите плитку, чтобы отобразить команды плитки, затем выберите и перетащите на панели команд плитки, чтобы перетащить выбранную плитку на новое место.

Чтобы помочь вам выровнять плитки, при перемещении плитки отображается фоновая сетка.

Чтобы переместить несколько плиток одновременно

1. Удерживая Ctrl, щёлкните плитки, которые хотите переместить.

  * Каждая выбранная плитка выделяется.
  * Общее количество выбранных плиток отображается на панели команд плитки.

2. Выберите и перетащите Переместить, чтобы перетащить все выбранные плитки на новое место.

Копирование и вставка плитки

Вы можете копировать и вставлять плитки на тот же дашборд или на другой дашборд.

Чтобы скопировать и вставить одну плитку

1. Выберите плитку, чтобы отобразить команды плитки.

2. На панели команд плитки выберите Копировать в буфер обмена.

  * Выбранная плитка копируется в буфер обмена.

3. Вставьте плитку (Ctrl-V).

  * Вы можете вставить скопированную плитку на текущий дашборд, что эквивалентно Дублировать.
  * Вы можете переключиться на другой дашборд и вставить скопированную плитку туда.

Чтобы скопировать и вставить несколько плиток одновременно

1. Удерживая Ctrl, щёлкните плитки, которые хотите скопировать и вставить.

  * Каждая выбранная плитка выделяется.
  * Общее количество выбранных плиток отображается на панели команд плитки.

2. На панели команд плитки выберите Копировать в буфер обмена (или используйте сочетание клавиш Ctrl-C).

  * Выбранные плитки копируются в буфер обмена.

3. Вставьте плитки (Ctrl-V) на тот же дашборд или переключитесь на другой дашборд и вставьте их туда.

Дублирование плитки

Вы можете дублировать одну плитку за раз или дублировать несколько плиток одновременно.

Чтобы дублировать одну плитку

1. Выберите плитку, чтобы отобразить команды плитки. 2. Выберите Дублировать.

В зависимости от наличия места на вашем дашборде, дубликат плитки размещается рядом с оригинальной плиткой или под ней, либо пространство оригинальной плитки уменьшается вдвое, чтобы освободить место для оригинала и дубликата. Если автоматическое размещение плиток не то, что вы хотите, вы, конечно, можете переместить дубликаты плиток вручную.

Выберите плитку и наведите курсор на кнопку Дублировать, чтобы увидеть, где будет размещён дубликат.

Чтобы дублировать несколько плиток одновременно

1. Удерживая Ctrl, щёлкните плитки, которые хотите дублировать.

  * Каждая выбранная плитка выделяется.
  * Общее количество выбранных плиток отображается на панели команд плитки.

2. На панели команд плитки выберите Дублировать.

Разделение пространства плитки для вставки новой плитки

При компоновке дашборда вы можете разделить пространство, которое плитка использует в сетке, и вставить вторую плитку рядом с первой плиткой в том же пространстве.

  • Первая плитка не затрагивается, за исключением того, что теперь она использует половину ширины или высоты, которую использовала до разделения пространства.
  • Вторая (новая) плитка использует другую половину этого пространства макета.
  • Это доступно только при выборе одной плитки, достаточно большой для разделения. Это недоступно при выборе нескольких плиток или если размер выбранной плитки слишком мал для разделения.

Например, давайте выберем плитку и добавим ещё одну плитку справа от неё, чтобы две плитки делили пространство, изначально используемое первой плиткой.

1. Выберите плитку.

2. Наведите курсор на плитку, чтобы увидеть элементы управления разделением — влево, вправо и вниз — чтобы указать, где вы разделяете это пространство и вставляете новую плитку.

3. В этом примере выберите элемент управления справа. Открывается меню, аналогичное меню, которое вы бы использовали для добавления плитки на дашборд.

4. Выберите тип плитки, который хотите добавить.

5. Отредактируйте определение новой плитки и закройте панель редактирования, чтобы увидеть изменённый макет.

  * Оригинальная плитка не изменена, за исключением того, что теперь она использует только левую половину пространства, которое использовала раньше.
  * Новая плитка использует правую половину этого пространства.

6. Вы всё ещё можете вручную настроить размеры и положение плиток.

Удаление плитки

Вы можете удалить одну плитку за раз или выбрать и удалить несколько плиток одновременно.

Чтобы удалить одну плитку

1. Выберите плитку, чтобы отобразить команды плитки.

2. На панели команд плитки выберите Дополнительные действия > Удалить.

Чтобы удалить несколько плиток одновременно

1. Удерживая Ctrl, щёлкните плитки, которые хотите удалить.

  * Каждая выбранная плитка выделяется.
  * Общее количество выбранных плиток отображается на панели команд плитки.

2. На панели команд плитки выберите Удалить.